Articles of rvm

Erklären Sie RVM, die Ruby-Version am Git-Checkout zu überprüfen

Ich benutze RVM und setze die Ruby-Version in meiner Gemfile. Da ich gerade daran arbeite, meine App auf eine neue Version zu aktualisieren, habe ich Niederlassungen mit verschiedenen Versionen. Jedes Mal, wenn ich zu oder von diesen Zweigen cd.. && cd project_directory , habe ich cd.. && cd project_directory , um RVM dazu zu bringen, […]

Die aktive Ruby-Version in der Linux-Umgebung kann nicht permanent über RVM beeinflusst werden, wenn der Befehl innerhalb des Shell-Skripts ausgeführt wird

Also, zum größten Teil dieses Abends, habe ich mit einem Bash-Skript gekämpft, das ich schreibe, um zu helfen, meine Entwicklungsumgebung beim Erstellen eines neuen Rails-Projekts von Grund auf zu rationalisieren / zu automatisieren / bootstrap (wie auch immer Sie es nennen wollen). Ich schreibe das Skript modular, das heißt, schreibe selbständig Scriptlets, die unabhängig vom […]

Installation von Nokogiri 1.4.3 gem

Installation von Nokogiri 1.4.3 gem. Nokogiri 1.6.6.2 installiert ohne Probleme. Verwenden der neuesten RVM unter Ubuntu. pm@sniegas:~$ gem install nokogiri -v '1.4.3' Fetching: nokogiri-1.4.3.gem (100%) Building native extensions. This could take a while… ERROR: Error installing nokogiri: ERROR: Failed to build gem native extension. /home/pm/.rvm/rubies/ruby-2.2.1/bin/ruby -r ./siteconf20150519-7580-2yzgsg.rb extconf.rb *** extconf.rb failed *** Could not create […]

Ich denke, ich benutze eine rvm installierte Version von Ruby, aber Bash erkennt nicht den Befehl rvm

Ich glaube nicht, dass ich jemals Rvm auf meinem lokalen Rechner installiert habe … Ich habe es in einer IDE (EDIT: die IDE ist Nitrous.io) installiert, wie es in einem Tutorial (Coder Manual) beschrieben wurde. Wenn ich ruby -v in bash ruby 2.0.0p481 (2014-05-08 revision 45883) [universal.x86_64-darwin14] , bekomme ich ruby 2.0.0p481 (2014-05-08 revision 45883) […]

Aktualisieren von Ruby-Version und Gems, Fehler beim Aktualisieren von Juwelen

Ich benutze die IDE Cloud9 und wollte die Ruby-Version (von 2.1.5 auf 2.2.1) upgraden. Nach der Installation von RVM habe ich gesagt, dass rvm use 2.2.1 und die Ruby-Version in Gemfile auf 2.2.1 geändert hat. Dann habe ich bundle install und folgendes Ergebnis erhalten: Fetching gem metadata from https://rubygems.org/………. Fetching version metadata from https://rubygems.org/… Fetching […]

"FEHLER: Fehler beim Erstellen einer gem nativen Erweiterung." Bei der Installation von Rails

Ich versuche, Rails zu installieren. Ich habe RVM installiert, dann die neueste Ruby-Version (funktioniert), aber die Installation von Rails schlägt folgendermaßen fehl: serge1peshcoff@myLaptop:~$ gem install rails Building native extensions. This could take a while… /home/serge1peshcoff/.rvm/rubies/ruby-2.2.1/lib/ruby/site_ruby/2.2.0/rubygems/ext/builder.rb:73: warning: Insecure world writable dir /allext/soft_without_install in PATH, mode 040777 ERROR: Error installing rails: ERROR: Failed to build gem native […]

Installieren von RVM und Gems unter OSX über ein einzelnes Shell-Skript

Ich versuche, RVM und ein paar Edelsteine ​​aus einem einzigen Bash-Skript zu installieren, mit dem ich eine neue Entwicklungsbox bootst. Mein Ziel ist es, ein einzelnes Skript zu haben, das ich auf einer sauberen Installation von OSX ausführen kann, um alles, was ich für die Entwicklung verwende, zu installieren. Nach der Installation von RVM $HOME/.rvm/scripts/rvm […]

Bei der Installation von RedCloth (4.2.7) ist ein Fehler aufgetreten, und Bundler kann nicht fortfahren

Ich habe eine App auf dem Heroku Bamboo Stack und folge den statementen hier ( https://devcenter.heroku.com/articles/cedar-migration ) für die Migration auf den Cedar Stack. Meine App hat eine ältere Version von RefineryCMS (1.0.3) und ich versuche zu vermeiden, mit einem Upgrade dort zu arbeiten (für jetzt), und so habe ich Rails bei 3.0.9 behalten. Immerhin […]

Die Migration der database schlägt nach dem Upgrade auf Ruby 2.3.0 fehl

Ich habe auf Ruby 2.3.0 aktualisiert und habe einige Probleme beim Erstellen einer neuen Rails-App. Nach dem Erstellen einer einfachen neuen Test-App und dem Erstellen einer Ressource beim Versuch, rake db:migrate auszuführen, rake db:migrate ich den folgenden Ladeerrors: MacBook-Pro:log medright1$ rake db:migrate /Users/medright1/.rvm/rubies/ruby-2.3.0/lib/ruby/gems/2.3.0/gems/rake-10.4.2/bin/rake:31:in `require': cannot load such file — rake (LoadError) from /Users/medright1/.rvm/rubies/ruby-2.3.0/lib/ruby/gems/2.3.0/gems/rake-10.4.2/bin/rake:31:in `<top (required)>' […]

Linux – laufendes root installiertes Programm als nicht root

Ich habe RVM, dann Ruby 2.3.0 und Rails 4.2.5 als Super-User installiert. Ich kann auf das Programm als root zugreifen, aber nicht als normaler Benutzer. # rails -v Rails 4.2.5 $ rails -v /usr/bin/env: ruby1.9.1: No such file or directory Muss ich das Programm löschen und neu installieren oder gibt es eine Umgehungsmöglichkeit? Entschuldigung, das […]