Articles of rubygems

Installation von Nokogiri 1.4.3 gem

Installation von Nokogiri 1.4.3 gem. Nokogiri 1.6.6.2 installiert ohne Probleme. Verwenden der neuesten RVM unter Ubuntu. pm@sniegas:~$ gem install nokogiri -v '1.4.3' Fetching: nokogiri-1.4.3.gem (100%) Building native extensions. This could take a while… ERROR: Error installing nokogiri: ERROR: Failed to build gem native extension. /home/pm/.rvm/rubies/ruby-2.2.1/bin/ruby -r ./siteconf20150519-7580-2yzgsg.rb extconf.rb *** extconf.rb failed *** Could not create […]

Der Thurubyracer wird nicht unter Windows installiert

Beim Versuch, Juwel zu installieren, erhalte ich folgenden Fehler C:\xampp\htdocs\mg>gem install therubyracer Temporarily enhancing PATH to include DevKit… Building native extensions. This could take a while… ERROR: Error installing therubyracer: ERROR: Failed to build gem native extension. C:/RailsInstaller/Ruby2.1.0/bin/ruby.exe -r ./siteconf20150527-5032-1urwkwd. rb extconf.rb creating Makefile The system cannot find the path specified. The system cannot find […]

Errno :: EACCES: Berechtigung verweigert beim Erstellen neuer App Ruby on Rails

Nach der Installation frischen Ruby (v 2.2.2) und Rails (v 4.2.1). Ich versuche, neue App erstellen, indem ich rails new app in meinem Terminal commnad rails new app . Aber printingerrors wie folgt: Errno::EACCES: Permission denied @ dir_s_mkdir – /usr/local/var/rbenv/versions/2.2.2/lib/ruby/gems/2.2.0/extensions/x86_64-darwin-14/2.2.0-static/byebug-5.0.0 An error occurred while installing byebug (5.0.0), and Bundler cannot continue. Make sure that `gem […]

"OpenSSL kann nicht benötigt werden", wenn versucht wird, Ruby-Edelsteine ​​unter OS X zu installieren

Da ich auf OS X 10.10 Yosemite aktualisiert habe, erhalte ich den folgenden Fehler, wenn ich versuche, einen Ruby-Edelstein zu installieren: ERROR: While executing gem … (Gem::Exception) Unable to require openssl, install OpenSSL and rebuild ruby (preferred) or use non-HTTPS sources Aber wenn ich which openssl , zeigt es mir den path: /usr/local/bin/openssl Ich habe […]

Rails, default.js ist leer und jquery und jquery_ujs sind nicht geladen

Ich übe Ruby on Rails mit Railsführungen . Im Abschnitt 5.13 Artikel löschen zeigen sie, wie die Löschfunktion (destroy) erstellt wird. Ich habe die Schritte korrekt befolgt, aber der Löschbestätigungsdialog wird nicht angezeigt und die Artikel werden nicht gelöscht. Wenn ich die chrome-Entwickler-Tools überprüfte, ist "jquery" und "jquery_ujs" nicht enthalten und "default.js" ist leer. Ich […]

Rails server funktioniert nicht (LoadErrror mysql2) Windows

Ich versuche, Rails server-Befehl ausführen, aber es zeigt mysql2 Load Error. Ich werde mein Fehlerprotokoll hier platzieren Ich habe viele Orte durchsucht. Ich habe versucht, von meinem Bundle selbst zu installieren, indem ich den Befehl "gem install mysql2 –ruby = platform" benutze, indem ich die file c "libmysql.dll" benutze, die in ruby ​​/ bin eingefügt […]

RubyGems kann nicht mehr ohne Sudo ausgeführt werden

Ich verwende OSX 10.10.5. Nach der Aktualisierung von Rubygems auf die neueste Version (2.4.8) kann ich keine Edelsteine ​​mehr ohne Sudo laufen lassen. Ich bekomme ein einfaches permission denied: myGem Die permissions der file nach der Installation mit sudo gem install myGem in / usr / bin sind -rwx—— 1 root wheel 531B Aug 24 […]

einschließlich ausführbare file mit gem

Der fragliche Edelstein ist auf meinem GitHub Ich bin auch auf Linux, speziell Ubuntu. Ich versuche, das Juwel für Linux / OSX-Benutzer zu diesem timepunkt kompatibel zu machen, mit einem Fokus auf Windows-Benutzer, nachdem es für * nix-Systeme korrekt funktioniert. Also habe ich ein Juwel namens " fails . Es kann verwendet werden, um eine […]

Der Edelstein 'pg (= 0.12.4) ruby' wurde in keiner Edelsteinquelle gefunden, die in deiner Gemdatei aufgeführt oder auf diesem System verfügbar ist

Ich versuche folgendes auf meiner Kali-Box auszuführen, siehe Fehler. root@kali:~# ruby /usr/share/metasploit-framework/tools/nasm_shell.rb Could not find rake-10.4.2 in any of the sources Run `bundle install` to install missing gems. Ich führe dann die Bundle-Installation aus und erhalte den folgenden Fehler: Could not find gem 'pg (= 0.12.4) ruby' in any of the gem sources listed in […]

Kann Ruby Gems nicht installieren (Ubuntu 15.04) – "Netzwerk ist nicht erreichbar"

Ich versuche Jekyll auf einem neuen Vultr VPS mit Ubuntu 15.04 zu installieren. Ich habe Apache2 vorläufig manuell installiert (ich beabsichtige, es später für NodeJS zu verschrotten). Ich versuche, Jekyll zu installieren, aber es gibt mir den folgenden Fehler: ********@************:~$ gem install jekyll ERROR: While executing gem … (Errno::ENETUNREACH) Network is unreachable – sendto(2) for […]